NETLink® PRO family

Application Examples with RFC 1006

Edition 7 / 05.11.2017

Helmholz products
S7/S5 OPC-Server V4.10.2.9117 (Company Helmholz)

Products of other manufacturers
INAT-OPC-Server (INAT GmbH)
Indusoft Web Studio V7.0 (Indusoft)
InTouch V9.5 (Wonderware GmbH)
KEPserverEx V5.4.135.0 (KEPware Inc.)
PROCON-Win V5.3 (GTI Control)
VisAM Win32 (VISAM GmbH)
WinCC V7.4 (Siemens AG)
WinCC flexible 2005/2007 (Siemens AG)
ZenOn V6.2 (COPA-DATA)
All rights are reserved, including those of translation, reprinting, and reproduction of this manual, or parts thereof. No part of this manual may be reproduced, processed, copied, or transmitted in any way whatsoever (photocopy, microfilm, or other method) without the express written permission of Helmholtz GmbH & Co.KG, not even for use as training material, or using electronic systems. All rights reserved in the case of a patent grant or registration of a utility model or design.

Copyright © 2009 by

**Helmholtz GmbH & Co.KG**

Hannberger Weg 2, 91091 Grossenseebach, Germany

**Note:**

We have checked the content of this manual for conformity with the hardware and software described. Nevertheless, because deviations cannot be ruled out, we cannot accept any liability for complete conformity. The information in this manual is regularly updated. When using purchased products, please heed the latest version of the manual, which can be viewed in the Internet at www.helmholz.com, from where it can also be downloaded.

Our customers are important to us. We are always glad to receive suggestions for improvement and ideas.

STEP, Protocool, Starter, Micromaster, and SIMATIC are registered trademarks of SIEMENS AG. MS-DOS and Windows are registered trademarks of Microsoft Corporation.
Revision history of this document:

<table>
<thead>
<tr>
<th>Edition</th>
<th>Date</th>
<th>Revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>07.05.2008</td>
<td>First edition</td>
</tr>
<tr>
<td>2</td>
<td>07.04.2010</td>
<td>PRO family updated</td>
</tr>
<tr>
<td>3</td>
<td>29.11.2010</td>
<td>KEPserverEx V5.4.135.0 updated</td>
</tr>
<tr>
<td>4</td>
<td>04.07.2011</td>
<td>Helmholtz OPC Server V4.0.6.4908 updated</td>
</tr>
<tr>
<td>5</td>
<td>05.08.2011</td>
<td>Added Indusoft Web Studio V7.0 and PROCON-Win V5.3</td>
</tr>
<tr>
<td>6</td>
<td>15.08.2012</td>
<td>Added WINCC V7.0</td>
</tr>
<tr>
<td>7</td>
<td>04.10.2017</td>
<td>Added WINCC V7.4</td>
</tr>
<tr>
<td>8</td>
<td>30.10.2017</td>
<td>KEPServer V6.2.429.0 updated</td>
</tr>
</tbody>
</table>
## Contents

1. **Overview**  
   1.1 Application and function description  
   1.2 Information in the figures  
2. **RFC 1006 Activation via the Web Interface**  
   2.1 Requirements  
   2.2 Adapting the configuration side  
3. **Helmholz OPC-Server V4.12.0.11527**  
   3.1 Configuration of the communication partner  
   3.2 Setting up the OPC Toolbox demo client  
4. **INAT-OPC-Server (INAT GmbH)**  
   4.1 Configuring the INAT OPC server  
   4.2 INAT-OPC Client  
5. **Indusoft Web Studio V7.0**  
   5.1 Configuring the Indusoft communication driver  
   5.2 Setting up values to visualize  
6. **InTouch V9.5 (Wonderware GmbH)**  
   6.1 Starting the System Management Console  
   6.2 Configuring the Device Group  
   6.3 Configuring the Wonderware Client  
7. **KEPserverEx V6.2.429.0 (KEPware Inc.)**  
   7.1 Configuring KEPserverEx  
   7.2 Starting the OPC quick Client  
8. **PROCON-Win V3.2 (GTI Control)**  
   8.1 Configuring the driver and connection  
   8.2 Creating a Picture  
9. **VisAM Win32 (VISAM GmbH)**  
   9.1 Configuring VisAM Win 32  
   9.2 Starting visualization
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Application</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>WinCC V7.4</td>
<td>45</td>
</tr>
<tr>
<td>10.1</td>
<td>Add the protocol driver</td>
<td>45</td>
</tr>
<tr>
<td>10.2</td>
<td>Creating a variable</td>
<td>46</td>
</tr>
<tr>
<td>11</td>
<td>WinCC flexible 2005/2007</td>
<td>48</td>
</tr>
<tr>
<td>11.1</td>
<td>Configuring connections</td>
<td>48</td>
</tr>
<tr>
<td>11.2</td>
<td>Configuring the PG/PC interface</td>
<td>49</td>
</tr>
<tr>
<td>12</td>
<td>ZenOn V6.2</td>
<td>50</td>
</tr>
<tr>
<td>12.1</td>
<td>Configuring Zenon</td>
<td>50</td>
</tr>
<tr>
<td>12.2</td>
<td>Setting the driver</td>
<td>51</td>
</tr>
<tr>
<td>12.3</td>
<td>Driver configuration</td>
<td>51</td>
</tr>
<tr>
<td>12.4</td>
<td>Integrating variables in images</td>
<td>52</td>
</tr>
<tr>
<td>13</td>
<td>Address conversion table</td>
<td>53</td>
</tr>
<tr>
<td>14</td>
<td>Troubleshooting</td>
<td>54</td>
</tr>
<tr>
<td>15</td>
<td>Directory of Sources</td>
<td>56</td>
</tr>
</tbody>
</table>
1 Overview

1.1 Application and function description

This document is intended as a supplement to the NETLink® product line manuals.

Many visualization manufacturers support the TCP/IP protocol ‘RFC1006’ also known as ‘ISO on top of TCP’ to be able to communicate with S7-300/S7-400 systems, for example.

If this ‘RFC1006’ function is activated for example in the NETLink® PRO, explicit adaptations must be made to the software products. This manual describes step by step the basic settings of a small selection of visualization solutions for transferring data via this communication path.

In firmware versions from 2.3 of the NETLink® PRO family adapters the “RFC1006” function is always active.

It is assumed that the reader is familiar with the development environment of the software solutions mentioned in this document, as only the points specific to the connection are described.

More extensive support with commissioning and parameterization of the various SCADA-, HMI/OPC server systems is available directly from the manufacturers in question.

At this point is not described how a Internet teleservice via VPN and port forwarding is implemented with a NETLink® Ethernet gateway.

1.2 Information in the figures

Many of the figures in this document contain settings and directions for use marked or highlighted in red.
2 RFC 1006 Activation via the Web Interface

The examples described here are based on NETLink models with firmware versions less than V2.3 (e.g. NETLink ® PRO). Prior to the use with this device the RFC 1006 functionality has to be set manually.

A detailed description is also given in the accordingly manual! We generally recommend upgrading your NETLink® products with the last firmware version, so you can always use the latest features.

2.1 Requirements

The NETLink® Ethernet gateway is connected to the PC via a network card. One of the SCADA/OPC server programs described below is also installed on this PC. The Webinterface function must not be deactivated. It is accessed via one of the installed Internet browsers (for example, Mozilla Firefox, Opera, Konqueror, or Internet Explorer).

You do not need to install any additional drivers for the NETLink®.

The applications described here were performed on the Window XP operating system with service package 2 and 3.

2.2 Adapting the configuration side

As soon as the Web interface is opened by entering the relevant URL ‘http://<ip address>’, the link to “Configuration” opens. As soon as you have answered the security query, you can write to all parameters.

From version 2.3 there is a text field: "RFC mode is always activated". In this case, you can skip this section.

The ‘RFC 1006 interface ON/OFF’ option is activated by entering “ON” and confirming with the “OK” button (see Fig.)

In the next window, the settings are displayed again and must be confirmed with “OK” before they are finally transferred to the NETLink® device.

The following figure shows the configuration screen in the NETL ink ® PRO web interface. In the current firmware versions of other NETLink ® Ethernet variants is this manual assignment not necessary.
Rebooting can take up to 15 seconds.

After the new parameterization data have been stored, the NETLink® PRO is restarted to activate the new configuration.
3 Systeme Helmholz OPC-Server V4.12.0.11527

The following steps must be performed in the described sequence (Version November 2017):

3.1 Configuration of the communication partner

Start the “Configuration S7-OPC Server” program module via Start/Programs/Systeme Helmholz/S7-OPC-Server:

- Select tab card “Devices”.
- In this example, click device 0 and then select “S7-TCP/IP” from the pull-down menu.

![Configuration S7-OPC Server](image)

- Go to the tab “Connections” in the right sub window.
- Click “Change…” to create a new connection.

![Create new connection](image)

It opens a new connection window.
• The PLC no. and Rack in this example is not relevant
• Enter the NETLink® address in the IP address field
• Enter the MPI address of the connected PLC in “Slot”
• Finally set the type of PLC you are working with.
• Close the window by clicking “OK”.

Complete your connection settings with “Apply“

Next, select the main tab “Connections”
• Click the Button “Scan”.

Enter the configured device number (possible 0 to 15). In this example -> 0
• Confirm with “OK”

The connection to the adapter should be established and displayed.
• The CPU can be determined with “Test” (this feature is optional and must not be executed in mandatory).

![Image of OPC Toolbox demo client](image)

• The connection test was successful and can be confirmed with “OK”.

The OPC server is now fully configured for a NETLink® to PLC connection.

If you want to set up multiple connections within a device, the “PLC no.” has to be unique for each connection. These numbers must be different.

3.2 Setting up the OPC Toolbox demo client

The following steps are provided as an example only and are not obligatory for customer applications. They serve as a visual check whether data exchange is taking place.

Start program module “OPC Toolbox demo client” with Start/Programs/Systeme Helmholz/S7-OPC-Server. The various tab cards are displayed below.

The “OPC Servers” field opens first:
• the tree structure can be open by clicking the plus sign in front of “Local”

• open “Data Access V3” in a similar manner
• open “Helmholz S7/S5 OPC Server” similarly
• Double-click “Helmholz.OPC.S7.DA.1”
• The “group” opens in the left field. The green circle indicates that the connection has been started.

Now switch to the “DA Browse” tab card.

• open “opcda://Helmholz.OPC.S7.DA.1/…” in the tree structure
• A device is displayed when it has been found (in this case “0.0”).
• On opening the device, the data access objects are searched from the CPU and then listed.
• Transfer the selected items into the left column by double clicking (multiple selections possible).
Now switch to the “DA Items” tab card.

- The connection quality status is displayed in the “Quality” column.
- Currently, only the permissible name range elements are displayed under “Value”.

- Every item can be edited by selecting it and then clicking the “Properties” button.

- The changes are adopted with “Apply” and “OK”.

Further examples of the syntax of various items:
4 INAT-OPC-Server (INAT GmbH)

The following steps must be performed in the described sequence (status May 2008):

4.1 Configuring the INAT OPC server

The following dialog box opens when you select “Configuration->AccessPathDefinition” from the menu:

A new connection is generated via menu “Configuration->New” in dialog box “Access Path Definition”.

The following dialog box opens.

When you have confirmed the new connection with the OK button, you can set the parameters in the subsequent dialog box:
The most important entries are:

- The IP address of the target station
- Connection properties RFC1006

The RFC1006 setting is configured via the "ISO-on-TCP" button.

4.2 INAT-OPC Client

Select the OPC Server.

Once the server is configured, you can access the data of the controller via the OPC Client.

You can select the OPC server from which the configured data will be fetched via menu item "File->New".
Configuring visualization data

- First of all, create a "Group"
- Menu “Group->Add Group…”

![Add New Group dialog]

- Then select menu “Item->Add Item…”
- Important! In field “Access Path” you must enter the name of the connection exactly as designated in the OPC server
- For "Item Name" enter the variable from the SPC
- Finally press button “Add Item” and then “OK”

![Add New OPC Item dialog]
5 Indusoft Web Studio V7.0

The following steps must be performed in the described sequence (status August 2011). The user should be familiar with IWS or at least have the “Getting Started” guide and the Indusoft-driver specs “SIETH” at hand.

5.1 Configuring the Indusoft communication driver

Choose the tab „Comm“ in „Project Explorer“, then right-click on “Drivers” and choose “Add/Remove drivers“:

![Image of Project Explorer and Drivers configuration]

Pick the “SIETH” driver out and add it by clicking “Select>” and confirm with “OK”:

![Image of Selecting and Confirming Drivers]

Press „Help“ before you select the driver in order to open the corresponding driver manual.
• In the „Project Explorer“, tab „Comm“ right-click on the driver “SIETH” and from the context menu choose “Settings”:

Under “Serial Encapsulation” choose “TCP/IP” and under “IP Address” enter the IP address of the NETLink. Everything else will be left default:
5.2 Setting up values to visualize

In the tree of the “Project Explorer” under “Drivers” -> “SIETH” you can find a “Main Driver Sheet”. Double-click either this or any other driver sheet:

On this “Driver Sheet” you have to configure any values you choose to visualize.

- After double-clicking the first empty cell in the column “Tag Name” a dialog window opens, in which to choose the tag to specify. In this example the tag is called “Mbyte”:
• Enter the IP address of the adapter, the rack number and the slot (the PLCs MPI address) under the column “Station” using this format:

<IP address> : <Rack> : <Slot>

• Adjacent enter the memory address of the variable you want to access on the PLC under the column “I/O Address” (for further information please consult the “SIETH” driver manual):
• Important for S7-200 users!
The V registers of the S7-200 can be read by stating the DB1 registers. (For further information please consult the “SEITH” driver manual):

• Save the “Driver-Sheet” and run the application. The value contained in flag byte 0 (VB0 in a S7-200) will be saved and displayed in the tag “Mbyte”.
6 InTouch V9.5 (Wonderware GmbH)
(System Management Console 2.0 Version 5.1)
The following steps must be performed in the described sequence (status July 2007):

6.1 Starting the System Management Console
"Start->Programs->Wonderware->System Management Console"

6.2 Configuring the Device Group
Enter Device Group (later the NETLink® will be addressed with this name from the WWClient)
6.3 Configuring the Wonderware Client

"Start -> Programs -> Wonderware Factory Suite -> Common-> WWClient" to establish connection

If the connection has been set correctly, the following display opens:

Configuring the item

If the Item configuration is correct and the SIDirect DAServer has been activated, the configured “Item” is updated in the “Wonderware Client” window.
7  KEPServerEx V6.2.429.0 (KEPware Inc.)

The following steps must be performed in the described sequence (status November 2017):

7.1  Configuring KEPServerEx

Start program module KEPServerEx, create a new project or right-click in the demo project and select “New Channel”.

Select device driver “Siemens TCP/IP Ethernet”
Enter a new name or leave the existing one and “Continue”

Select the computer’s own network card

Leave default optimizations and confirm with “Continue”.
Select the Floating-Point Values to “Unmodified” and confirm with “Continue”

Finish” the channel settings.

Select “Click to add a device” to assign the NETLink® as a device
Enter a new name or leave the existing one and “Continue”

Select device model “S7-300”

Enter the IP address of the connected NETLink® here.
Leave default timing and confirm with “Continue”.

No changes at this point “Continue”
No changes at this point “Continue”

The communications port for RFC 1006 is 102 (default)
The link type must be set to “OP”!

Leave byte order at “Big Endian (S7 Default)”.

![Image of Add Device Wizard with link type and byte order settings]
No changes at this point “Continue”

“Finish” the device settings.

The following steps are provided as an example only and are not obligatory for customer applications. They serve as a visual check whether data exchange is taking place.
By clicking “Click to add a static tag” in this example, only one item will be assigned.

The flag word zero will be processed in the sequential program of the connected CPU.

Complete with “Apply” and “OK”
7.2 Starting the OPC quick Client

The Quick Client can be started via the marked icon:

The program module *OPC Quick Client* opens and the status of the item is displayed by marking the channel and device you previously created.
8 PROCON-Win V3.2 (GTI Control)

The following steps must be performed in the described sequence (Version July 2011):

8.1 Configuring the driver and connection

- Open PROCON-WIN 5 VisuDesigner.
- Create a new project by pressing „New Project“

- Choose „Compact“ and name the project.
- Confirm with „OK“.
A new project is created and opened immediately.

- Double-click "Tag".

- From the menu bar click on "Tag" -> "Driver selection"

- Select "S5-S7-COMBI RFC 1006".

- Click the button contained in the cell under the column "INI-File".
A text editor opens.

Search for this in color highlighted line:

```
ag0 = "/type=s7_osi /ip_adr=XXX /rtsap=[02.0Y] /wtsap=[02.0Y] /ltsap=[02.0Y] /uni=yes"
```

The highlighted line is to be replaced with the following:

```
ag0 = "/type=s7_osi /ip_adr=XXX /rtsap=[02.0Y] /wtsap=[02.0Y] /ltsap=[02.0Y] /uni=yes"
```

In place of the “XXX” enter the IP address of the NETLink

Replace every “Y” with the MPI address of the PLC connected to the NETLink

The resulting string should look something like this:

```
ag0 = "/type=s7_osi /ip_adr=XXX /rtsap=[02.0Y] /wtsap=[02.0Y] /ltsap=[02.0Y] /uni=yes"
```

Close the text editor and driver selection screen by pressing “OK”

From the menu bar press „Tag“ -> „New“ -> „Num“.
• Fill the table with the following values:

<table>
<thead>
<tr>
<th>Name</th>
<th>user-defined</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decimal places</td>
<td>0</td>
</tr>
<tr>
<td>Min PLC</td>
<td>-128</td>
</tr>
<tr>
<td>Max PLC</td>
<td>127</td>
</tr>
<tr>
<td>Min PC</td>
<td>0</td>
</tr>
<tr>
<td>Max PC</td>
<td>256</td>
</tr>
<tr>
<td>Driver</td>
<td>S5-S7-COMBI RFC 1006</td>
</tr>
<tr>
<td>IO</td>
<td>Input</td>
</tr>
<tr>
<td>Baustein-Typ</td>
<td>MERKER</td>
</tr>
<tr>
<td>Format</td>
<td>S7-BYTE</td>
</tr>
</tbody>
</table>

• Values not defined above are left at default.

• Save the project (STRG+S).

8.2 Creating a Picture

• Right-click on “Pictures“ and select “New”.

• A new Picture is created and displayed
• Click the tab “Dynamic“ under “Items“ and then “Numeric Field“
• Now right-click on the white area beneath “Dynamic Symbol” and choose “New” -> “Numeric Digit”.

• Press the button contained in the cell under column “Instance Value” row “Value”.

• Choose the afore created tag and close the window with “OK”.
• Close “Numberfield Control” by pressing “OK”.
• Create an instance of the newly created numeric digit by pulling it on the picture using drag & drop.

• Save the project (CTRL+S) and from the menu bar press “File” -> “Create Runtime”.

• Open the Windows start menu and select “Aktuelles Projekt” under “All programs” -> “GTT” -> “PROCON-WIN 5.3”

If no start menu entry exists, you can find the file “projects.pcs” in the folder “\PROCON\WIN\Projects”. It can be opened with a text-editor!
• Enter the name of the project in the text file and save it.

• Now start „PROCON-WIN 5 VisuCompact“.
• A numeric field containing the content of the flag byte 0 in decimal format should be visible now.

• To close VisuCompact double tap “Esc”
9  VisAM Win32 (VISAM GmbH)

The following steps must be performed in the described sequence (status May 2008):

9.1  Configuring VisAM Win 32

Open the program module VisAM editor

- Communication -> Select channels
- Click assignment 1 in the communication channel selection.

In the selection, select assignment “Siemens S7 Ethernet ISO on TCP” as the VKM name and confirm with “Continue”.

Click the remote name and…
...enter the IP address of the NETLink®

Confirm with “OK” and click TSAP...

...and enter address. In this case 2/2 for bus address 2, rack 0, slot 2 (see the relevant chapters with the “Address conversion table” in the NETLink® manual).

Confirm with “OK”.

You have now created the communications channel and can apply the settings with “Close”.
Select Communication -> VDF Data Field

Select Group 0 and click the “000” field to activate process variable selection.

Coupling channel 1 is referenced to the previously defined communications channel. Confirm with “OK”.

Save the settings.
9.2 Starting visualization

Select Project -> Test (hotkey F5)

Select "Online UL" and click "Start"

Process visualization opens and the communications link is started.

The connection monitor switches from "offline" to "online" mode.

The transmission information can be displayed in Info.
10 WinCC V7.4 (Siemens AG)

The following steps must be performed in the described sequence (Version November 2017):

10.1 Add the protocol driver

To parameterize a RFC1006 link in a WinCC project, a new TCP/IP link must first be created in the ‘SIMATIC S7 PROTOCOL SUITE.’

- Right click: Tag Management -> Add new driver…
- Select: SIMATIC S7 Protocol Suite.chn

- create a new TCP/IP connection in SIMATIC S7 PROTOCOL SUITE
- ‘Open’ the Tag management.
With right-click: TCP / IP -> System parameter you have to select the correct logical device name in the ‘Unit’ tab.

In this case, the NETLink® Gateway has the IP address 172.16.0.49

- click on ‘Properties’
- type in the IP address of the NETLink device
- Enter the rack/slot combination of the end device

Here 172.16.0.49 and 0, 2.

The destination CPU with which we want to communicate has the bus address 2.

10.2 Creating a variable

Under this connection we have just configured, we now have to create a variable.

This is done by right-clicking to open the context menu of the new connection and selecting ‘New variable…’.
In the properties window of the variable, which was named ‘merker’ in this case, we can now select the type of variable by clicking the ‘Select’ button.

Marker byte 0 is configured here.

The following screenshot shows that a variable named ‘merker’ now exists under the ‘newconnection_1’ connection.

If this variable is now included in the initial screen of the WinCC project, for example, a connection will be established to the CPU with address 2 via the NETLink® Gateway to read or write marker byte 0 from this address.

Further variables of different types can, of course, be created and used according to the same scheme.

It is also possible to create additional TCP/IP connections in order to communicate not only with the CPU with bus address 2 but also with other CPUs.
11 WinCC flexible 2005/2007 (Siemens AG)

The following steps must be performed in the described sequence (status April 2008):

11.1 Configuring connections

Start WINCC flexible Project and open the connections in the communications register:

- Select communications driver "SIMATIC S7 300/400"
- Interface: Ethernet
- The operator panel address is the local IP address of the computer network card
- Access point: S7ONLINE
- The Control address is the IP address set in NETLink®
- The Slot is the MPI address of the CPU to be addressed
11.2 Configuring the PG/PC interface

In the control panel, open the “Setting the PG/PC Interface” module.

- Select the network card with protocol “TCP/IP” installed in the computer system as the “Used Interface Parameterization”.
- Check whether “S7ONLINE (Step7) --> TCP/IP -->…” is active for “Access point of application”.
- Confirm with “OK”.

All variables that are linked to “Controller_1” can now be accessed via the RFC 1006 protocol.
12 ZenOn V6.2 (COPA-DATA)

The following steps must be performed in the described sequence (status August 2007):

12.1 Configuring Zenon

Start Zenon and create a new project or adapt an existing one and define variables.

Configuring variables:
12.2 Setting the driver

- Mark “S7 TCP-IP”
- Press “Click here->” in the configuration

12.3 Driver configuration

- “New” button:
- Enter data
  (remote IP address = IP address from NETLink® Remote TSAP = MPI address of PLC)
- First the “Save” button
- Then “OK” button

First the “Save” button and only then confirm “OK”.
12.4 Integrating variables in images

Configuring images

Finally, start the runtime:
### 13 Address conversion table

The following table is a parameterization aid for fining the correct settings for Routing over RFC or for remote TSAP in addressed mode. Please note that the rack and slot together fill only one byte which is divided as follows:

- Rack fills the upper three bits (11100000_bin)
- Slot fills the lower five bits (00011111_bin)

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0200</td>
<td>32</td>
<td>1</td>
<td>0</td>
<td>0230</td>
<td>64</td>
<td>2</td>
<td>0</td>
<td>0240</td>
<td>96</td>
<td>3</td>
<td>0</td>
<td>0260</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>0201</td>
<td>33</td>
<td>1</td>
<td>1</td>
<td>0221</td>
<td>65</td>
<td>2</td>
<td>1</td>
<td>0241</td>
<td>97</td>
<td>3</td>
<td>1</td>
<td>0261</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>2</td>
<td>0202</td>
<td>34</td>
<td>1</td>
<td>2</td>
<td>0222</td>
<td>66</td>
<td>2</td>
<td>2</td>
<td>0242</td>
<td>98</td>
<td>3</td>
<td>2</td>
<td>0262</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
<td>3</td>
<td>0203</td>
<td>35</td>
<td>1</td>
<td>3</td>
<td>0223</td>
<td>67</td>
<td>2</td>
<td>3</td>
<td>0243</td>
<td>99</td>
<td>3</td>
<td>3</td>
<td>0263</td>
</tr>
<tr>
<td>4</td>
<td>0</td>
<td>4</td>
<td>0204</td>
<td>36</td>
<td>1</td>
<td>4</td>
<td>0224</td>
<td>68</td>
<td>2</td>
<td>4</td>
<td>0244</td>
<td>100</td>
<td>3</td>
<td>4</td>
<td>0264</td>
</tr>
<tr>
<td>5</td>
<td>0</td>
<td>5</td>
<td>0205</td>
<td>37</td>
<td>1</td>
<td>5</td>
<td>0225</td>
<td>69</td>
<td>2</td>
<td>5</td>
<td>0245</td>
<td>101</td>
<td>3</td>
<td>5</td>
<td>0265</td>
</tr>
<tr>
<td>6</td>
<td>0</td>
<td>6</td>
<td>0206</td>
<td>38</td>
<td>1</td>
<td>6</td>
<td>0226</td>
<td>70</td>
<td>2</td>
<td>6</td>
<td>0246</td>
<td>102</td>
<td>3</td>
<td>6</td>
<td>0266</td>
</tr>
<tr>
<td>7</td>
<td>0</td>
<td>7</td>
<td>0207</td>
<td>39</td>
<td>1</td>
<td>7</td>
<td>0227</td>
<td>71</td>
<td>2</td>
<td>7</td>
<td>0247</td>
<td>103</td>
<td>3</td>
<td>7</td>
<td>0267</td>
</tr>
<tr>
<td>8</td>
<td>0</td>
<td>8</td>
<td>0208</td>
<td>40</td>
<td>1</td>
<td>8</td>
<td>0228</td>
<td>72</td>
<td>2</td>
<td>8</td>
<td>0248</td>
<td>104</td>
<td>3</td>
<td>8</td>
<td>0268</td>
</tr>
<tr>
<td>9</td>
<td>0</td>
<td>9</td>
<td>0209</td>
<td>41</td>
<td>1</td>
<td>9</td>
<td>0229</td>
<td>73</td>
<td>2</td>
<td>9</td>
<td>0249</td>
<td>105</td>
<td>3</td>
<td>9</td>
<td>0269</td>
</tr>
<tr>
<td>10</td>
<td>0</td>
<td>10</td>
<td>020A</td>
<td>42</td>
<td>1</td>
<td>10</td>
<td>022A</td>
<td>74</td>
<td>2</td>
<td>10</td>
<td>024A</td>
<td>106</td>
<td>3</td>
<td>10</td>
<td>026A</td>
</tr>
<tr>
<td>11</td>
<td>0</td>
<td>11</td>
<td>020B</td>
<td>43</td>
<td>1</td>
<td>11</td>
<td>022B</td>
<td>75</td>
<td>2</td>
<td>11</td>
<td>024B</td>
<td>107</td>
<td>3</td>
<td>11</td>
<td>026B</td>
</tr>
<tr>
<td>12</td>
<td>0</td>
<td>12</td>
<td>020C</td>
<td>44</td>
<td>1</td>
<td>12</td>
<td>022C</td>
<td>76</td>
<td>2</td>
<td>12</td>
<td>024C</td>
<td>108</td>
<td>3</td>
<td>12</td>
<td>026C</td>
</tr>
<tr>
<td>13</td>
<td>0</td>
<td>13</td>
<td>020D</td>
<td>45</td>
<td>1</td>
<td>13</td>
<td>022D</td>
<td>77</td>
<td>2</td>
<td>13</td>
<td>024D</td>
<td>109</td>
<td>3</td>
<td>13</td>
<td>026D</td>
</tr>
<tr>
<td>14</td>
<td>0</td>
<td>14</td>
<td>020E</td>
<td>46</td>
<td>1</td>
<td>14</td>
<td>022E</td>
<td>78</td>
<td>2</td>
<td>14</td>
<td>024E</td>
<td>110</td>
<td>3</td>
<td>14</td>
<td>026E</td>
</tr>
<tr>
<td>15</td>
<td>0</td>
<td>15</td>
<td>020F</td>
<td>47</td>
<td>1</td>
<td>15</td>
<td>022F</td>
<td>79</td>
<td>2</td>
<td>15</td>
<td>024F</td>
<td>111</td>
<td>3</td>
<td>15</td>
<td>026F</td>
</tr>
<tr>
<td>16</td>
<td>0</td>
<td>16</td>
<td>0210</td>
<td>48</td>
<td>1</td>
<td>16</td>
<td>0230</td>
<td>80</td>
<td>2</td>
<td>16</td>
<td>0250</td>
<td>112</td>
<td>3</td>
<td>16</td>
<td>0270</td>
</tr>
<tr>
<td>17</td>
<td>0</td>
<td>17</td>
<td>0211</td>
<td>49</td>
<td>1</td>
<td>17</td>
<td>0231</td>
<td>81</td>
<td>2</td>
<td>17</td>
<td>0251</td>
<td>113</td>
<td>3</td>
<td>17</td>
<td>0271</td>
</tr>
<tr>
<td>18</td>
<td>0</td>
<td>18</td>
<td>0212</td>
<td>50</td>
<td>1</td>
<td>18</td>
<td>0232</td>
<td>82</td>
<td>2</td>
<td>18</td>
<td>0252</td>
<td>114</td>
<td>3</td>
<td>18</td>
<td>0272</td>
</tr>
<tr>
<td>19</td>
<td>0</td>
<td>19</td>
<td>0213</td>
<td>51</td>
<td>1</td>
<td>19</td>
<td>0233</td>
<td>83</td>
<td>2</td>
<td>19</td>
<td>0253</td>
<td>115</td>
<td>3</td>
<td>19</td>
<td>0273</td>
</tr>
<tr>
<td>20</td>
<td>0</td>
<td>20</td>
<td>0214</td>
<td>52</td>
<td>1</td>
<td>20</td>
<td>0234</td>
<td>84</td>
<td>2</td>
<td>20</td>
<td>0254</td>
<td>116</td>
<td>3</td>
<td>20</td>
<td>0274</td>
</tr>
<tr>
<td>21</td>
<td>0</td>
<td>21</td>
<td>0215</td>
<td>53</td>
<td>1</td>
<td>21</td>
<td>0235</td>
<td>85</td>
<td>2</td>
<td>21</td>
<td>0255</td>
<td>117</td>
<td>3</td>
<td>21</td>
<td>0275</td>
</tr>
<tr>
<td>22</td>
<td>0</td>
<td>22</td>
<td>0216</td>
<td>54</td>
<td>1</td>
<td>22</td>
<td>0236</td>
<td>86</td>
<td>2</td>
<td>22</td>
<td>0256</td>
<td>118</td>
<td>3</td>
<td>22</td>
<td>0276</td>
</tr>
<tr>
<td>23</td>
<td>0</td>
<td>23</td>
<td>0217</td>
<td>55</td>
<td>1</td>
<td>23</td>
<td>0237</td>
<td>87</td>
<td>2</td>
<td>23</td>
<td>0257</td>
<td>119</td>
<td>3</td>
<td>23</td>
<td>0277</td>
</tr>
<tr>
<td>24</td>
<td>0</td>
<td>24</td>
<td>0218</td>
<td>56</td>
<td>1</td>
<td>24</td>
<td>0238</td>
<td>88</td>
<td>2</td>
<td>24</td>
<td>0258</td>
<td>120</td>
<td>3</td>
<td>24</td>
<td>0278</td>
</tr>
<tr>
<td>25</td>
<td>0</td>
<td>25</td>
<td>0219</td>
<td>57</td>
<td>1</td>
<td>25</td>
<td>0239</td>
<td>89</td>
<td>2</td>
<td>25</td>
<td>0259</td>
<td>121</td>
<td>3</td>
<td>25</td>
<td>0279</td>
</tr>
<tr>
<td>26</td>
<td>0</td>
<td>26</td>
<td>021A</td>
<td>58</td>
<td>1</td>
<td>26</td>
<td>023A</td>
<td>90</td>
<td>2</td>
<td>26</td>
<td>025A</td>
<td>122</td>
<td>3</td>
<td>26</td>
<td>027A</td>
</tr>
<tr>
<td>27</td>
<td>0</td>
<td>27</td>
<td>021B</td>
<td>59</td>
<td>1</td>
<td>27</td>
<td>023B</td>
<td>91</td>
<td>2</td>
<td>27</td>
<td>025B</td>
<td>123</td>
<td>3</td>
<td>27</td>
<td>027B</td>
</tr>
<tr>
<td>28</td>
<td>0</td>
<td>28</td>
<td>021C</td>
<td>60</td>
<td>1</td>
<td>28</td>
<td>023C</td>
<td>92</td>
<td>2</td>
<td>28</td>
<td>025C</td>
<td>124</td>
<td>3</td>
<td>28</td>
<td>027C</td>
</tr>
<tr>
<td>29</td>
<td>0</td>
<td>29</td>
<td>021D</td>
<td>61</td>
<td>1</td>
<td>29</td>
<td>023D</td>
<td>93</td>
<td>2</td>
<td>29</td>
<td>025D</td>
<td>125</td>
<td>3</td>
<td>29</td>
<td>027D</td>
</tr>
<tr>
<td>30</td>
<td>0</td>
<td>30</td>
<td>021E</td>
<td>62</td>
<td>1</td>
<td>30</td>
<td>023E</td>
<td>94</td>
<td>2</td>
<td>30</td>
<td>025E</td>
<td>126</td>
<td>3</td>
<td>30</td>
<td>027E</td>
</tr>
<tr>
<td>31</td>
<td>0</td>
<td>31</td>
<td>022F</td>
<td>63</td>
<td>1</td>
<td>31</td>
<td>023F</td>
<td>95</td>
<td>2</td>
<td>31</td>
<td>025F</td>
<td>127</td>
<td>3</td>
<td>31</td>
<td>027F</td>
</tr>
</tbody>
</table>
14 Troubleshooting

The points described here show some typical errors that can occur when using the RFC 1006 function.

Please also refer to the descriptions for troubleshooting in the accordant NETLink® manual!

If a problem is not described here and this manual does not provide any information on how to remedy it, the support of Helmholz GmbH & Co.KG will gladly help you to solve the problem.

Q: How can I specify the target station(s) for RFC 1006 communications in WinCC by using the Rack/Slot fields?

A: Since the RFC protocol does not have a default entry for specifying the PROFIBUS/MPI address of a target station (PLC), you will have to use the 2 byte-long TSAP field. The first byte of the TSAP ID is the rack value, while the second is the slot value (the value range for the slot field will often have a maximum value of 31, e.g., in WinCC).

This is why the NETLink unit will have to evaluate both of the TSAP field bytes in order to determine the address of the target station.

Scenario 1: Your application allows slot field values of up to 126

--->
You will have to enter “0” into the Rack field and the PROFIBUS address of your CPU into the Slot field.

Scenario 2: Your application only allows slot field values of up to 31

--->
You will have to enter a 32x multiplier into the Rack field and the missing remainder of the PROFIBUS address into the Slot field.

Address assignments using the Rack and Slot input fields:

Example 1: Entry for address 17 ≡ Calculation: (0* 32 + 17)
Example 2: Entry for address 34 ≡ Calculation: (1* 32 + 2)
Example 3: Entry for address 69 ≡ Calculation: (2* 32 + 5)

Q: Why do I get an address conflict when trying to communicate via Step 7 with the RFC 1006 mode activated even though the station-related address has been adapted in the driver?

A: You have probably changed your own address in the Web interface (default = 0). The NETLink® automatically tries to go online with this address on the bus in RFC mode. Conflicts will occur if another node uses the same address. In this case, the altered entry in Step 7 is ignored. Check the status of the active stations in the Web interface.

Q: How is a firmware update performed in a NETLink® adapter?

A: The following steps must be performed:

1) Download the up-do-date “SHTools” software from the Company Helmholz web site and install this on your computer.
2) After “SHTools” has been started, make sure that the appropriate NETLink® product is activated on the status bar.

![Status Bar Screenshot](image)

If there appear another product, so simply press the right mouse button over the status bar and select the product based on its name and order number in the dialog box that then opens.

3) After you have pressed the “Adapter->Update adapter” menu, the dialog box shown below appears (example):

![Update Adapter Dialog](image)

To perform an update from a firmware version lower than V1.42 to a version higher than V1.42, it is first necessary to update to version 1.42 as an intermediate step. After that, an update to all higher versions can be performed in a further step.

**Q:** What must I observe when calling your technical support?

**A:** Please have all relevant data of your system constellation with the connected stations and program modules at hand when you contact technical support at Helmholz GmbH & Co. KG.
15 Directory of Sources

INAT-OPC-Server
(http://www.inat.de/index.php?18&backPID=18&tt_products_sof=236)

InduSoft Web Studio v7.0
(http://www.indusoft.com/indusoftart.php?catid=1&name=IWS/webstudio)

InTouch V9.5 (Wonderware GmbH)
(http://global.wonderware.com/EN/Pages/WonderwareInTouch-HMI.aspx)

KEPserverEx V5.4.135.0
(http://www.kepware.com/Products/OPC_Servers.html)

PROCON-Win V5.3 (http://www.gti.de/index.php?id=45)

S7/S5 OPC-Server
(http://www.helmholz.de/prod.d,18_30_34.html?p_id=39)

VisAM Win32
(http://www.visam.de/03_produkte/visam/index.php)

WINCC V7.0

WinCC flexible 2005/2007
(http://www.automation.siemens.com/hmi/html_00/products/software/wincc-flexible/index.htm)

ZenOn V6.2 (http://www.copadata.at/de/ger/home.html)